macOS Catalina compatibility

System configuration, maintenance and utilities
User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

macOS Catalina compatibility

Post by G » 01 Aug 2019, 17:20

It's that time of year again!

This topic is for compatibility news or issues related to macOS Catalina (10.15).

NOTE: Catalina will no longer support 32-bit applications!

Updates may be made after we post. We will link directly to developer compatibility statements where possible. As always, triple check everything on your system before a major upgrade.

Users and developers, please post and update at will!
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

How to locate your 32-bit macOS apps

Post by G » 01 Aug 2019, 17:25

Go64

https://www.stclairsoft.com/Go64/

This is a free utility from St. Clair Software, the makers of Default Folder X, and it will locate 32-bit apps on your system.

Or go to  > About This Mac > System Report… > Software > Applications and click the "64-Bit (Intel)" column header to sort by compatibility.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 11 Sep 2019, 06:06

Native Instruments

https://support.native-instruments.com/ ... s-Products
WAIT TO UPDATE: macOS 10.15 Catalina

To ensure your Native products work the way they should, we recommend waiting to update. We’re working on making our software fully compatible with macOS 10.15. In the meantime check [the link above] for more information regarding your NI products and support for macOS Catalina.
Update 25 Nov 2019
After having conducted systematic tests, Native Instruments confirms full macOS Catalina compatibility with the latest versions of all current products*.

IMPORTANT NOTE: macOS 10.15 terminates the operability of some NI legacy hardware. This includes MASCHINE MK1, AUDIO 2 / 4 / 8 DJ and TRAKTOR S4 / X1 MK1.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 11 Sep 2019, 06:10

Slate Digital

https://slatedigital.zendesk.com/hc/en- ... 0035155994
UPDATE ALERT: CATALINA 10.15

We pride ourselves on customer experience, which is why we recommend that you WAIT to upgrade your operating system to 10.15 Catalina until further notice.

Our development team is working tirelessly to ensure that ALL Slate software is fully compatible with this update, and we will let you know as soon as we confirm that you can make that sweet, sweet music on 10.15.
Update 10 Feb 2020
MacOS Catalina (10.15.x) is now officially supported!
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 13 Sep 2019, 02:18

Audiority

https://www.facebook.com/groups/audiori ... 347861904/
OSX Users:
We are working to make our plugins compatible with the upcoming OSX Catalina. Please, be aware that in order to comply to the new OSX requirements, there will be no more 32bit versions of our plugin and the older OSX version will be 10.9
Update 15 Nov 2019

https://www.audiority.com/2019/11/07/ma ... port-list/
We are working to update all of our plugins to make them fully compatible with Mac OSX Catalina.

Here’s a list of the updated plugins as for November 15th, 2019:

– Distortion 1
– Echoes T7E mkII
– Heavy Pedal
– LDC2 Compander
– PlexiTape
– Pre X7
– The Abuser

We will update this list once a new updated plugin will be released. Most of our newest products should already work on Catalina without any problems, but to ensure full compatibility is advised to wait for a proper updated version of each product.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 13 Sep 2019, 18:33

FXpansion

(via email)
Given the upcoming release of macOS 10.15 Catalina, we’ve been performing in-house testing to establish the compatibility of FXpansion software with this macOS update.

Testing so far has revealed that changes introduced in macOS 10.15 may affect compatibility. So we recommend that you do not update to macOS 10.15 Catalina until we’ve ensured compatibility and given the all-clear that you’re safe to do so.

We’ll let you know once we’ve ensured that all existing products are no longer affected and that it's safe to update.

We'd like to apologise for any inconvenience this may cause, and thank you for your understanding and co-operation.

If you have any questions please feel free to get in touch with our support team here.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 17 Sep 2019, 09:36

GForce Software

https://www.gforcesoftware.com/support/ ... 5-catalina
Apple's forthcoming operating system upgrade moves users to the previously announced macOS 10.15 Catalina. Release is expected late September or early October, 2019.

A major change is the end of 32-bit support with only 64-bit software being compatible. Software not officially supported within Catalina may prove to be buggy or not even function at all.

Here at GForce, we have been working diligently updating our instruments to offer full compatibility with macOS Catalina. At the time of writing, our instruments are not yet fully compatible with the new macOS.

As a musician, engineer or producer we recommend you DO NOT upgrade to macOS Catalina until you are certain that all your software applications and plug-ins are fully compatible with the new system software so that your studio work remains uninterrupted.
Update
Do GForce instruments work with macOS 10.15 Catalina

Yes. Ensure you have installed the latest instrument version from My Instruments.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 17 Sep 2019, 17:03

Audio Damage

(via email)
macOS Catalina Is Coming.

As far as we're aware, our products are all Catalina-ready. However, with such a big change, we suggest waiting to upgrade until you hear from your DAW developer that your DAW of choice is compatible. As a recognized Apple developer, we are not technically subject to Notarization in its early stages; we are, however, Notarizing all updates as we release them.

To deal with the ongoing changes to macOS, we have begun a series of rolling updates to maintain compatibility. While doing these, we have to remove 32-bit compatibility on macOS for products that still had it, and are ending our support for 32-bit macOS. Eos 2, Discord 4, and Filterstation 2 have all been updated to have Notarized installers and had their 32-bit mode removed, with all other products to follow.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 23 Sep 2019, 18:38

U&I Software

(via email)
All of U&I's software products are programmed in 32bit. Apple has decided that MacOS 10.15 will run only 64bit applications. This requires Eric Wenger to reprogram the applications.

While he is working on them, please continue to use MacOS 10.6 through 10.14 on your computer, and consider holding off on upgrading to MacOS 10.15 until after the new versions have been completed. Another option is to setup a dual boot on your Mac. For more information on how click here.

The new versions are expected to be available by January 1st 2020.

U&I Software is the work of one person, and a group of volunteers who love it's unique products. We appreciate your support during this transition.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
Fikonhjul
Posts: 33
Joined: 05 Jul 2003, 03:01
Location: Sweden
Contact:

Re: macOS Catalina compatibility

Post by Fikonhjul » 30 Sep 2019, 14:19

Roland Cloud

(via email)
Roland Cloud software instruments are currently not supported by macOS Catalina. If you are using our products, we suggest that you do not install macOS Catalina at this time. We will let you know as soon as we offer compatibility. Refer to our FAQ section and our product specifications to obtain up-to-date info on our system requirements.

CHECK OUR FAQ HERE
Update 5 Dec 2019

https://www.rolandcloud.com/webview/new ... cOS-Update
MacOSCatalinaUpdate-NewsPage-Banner.jpg
Roland Cloud is now compatible with macOS Catalina (10.15). In order to ensure a seamless workflow, please update to RCM 2.4.2, and update your downloaded instruments before upgrading your operating system.
You do not have the required permissions to view the files attached to this post.
Main stuff: ProTools since 1991, Logic since 2003. Now on Logic Pro X. A labor of love: Vild i min mun

User avatar
Fikonhjul
Posts: 33
Joined: 05 Jul 2003, 03:01
Location: Sweden
Contact:

Re: macOS Catalina compatibility

Post by Fikonhjul » 30 Sep 2019, 14:23

Waves Audio

(via email)
Dear Waves user,

During October, Apple will release a new operating system, macOS 10.15 Catalina.

We are working closely with Apple to ensure that our software is compatible and that your Waves plugins and applications will work properly.

However, until we confirm full compatibility, we strongly recommend you remain on your current version of macOS.

In the meantime, please note:
  • Waves plugins v10 will open in macOS 10.15 Catalina but are not officially supported.
  • Waves’ eMotion LV1 mixer v10 will open in macOS 10.15 Catalina but is not officially supported.
  • Other Waves applications (MultiRack, StudioRack, SoundGrid Studio) are not supported and will not open in macOS 10.15 Catalina.
We will update you very soon about macOS 10.15 Catalina compatibility developments.

Best regards,
The Waves Team
Main stuff: ProTools since 1991, Logic since 2003. Now on Logic Pro X. A labor of love: Vild i min mun

User avatar
Fikonhjul
Posts: 33
Joined: 05 Jul 2003, 03:01
Location: Sweden
Contact:

Re: macOS Catalina compatibility

Post by Fikonhjul » 30 Sep 2019, 14:35

Sound Radix 32 Lives

Kind of obvious maybe, but as many of us might have hoped it could continue to resurrect old 32-bit stuff...

From forum.soundradix.com/t/32-lives-compatible-with-macos-10-15-catalina/845
On 3rd of June, 2019, Apple announced their upcoming macOS as part of the WWDC keynote.

Starting with macOS Catalina, 32-bit apps are no longer compatible with macOS.

32 Lives uses 32-bit code which is not compatible with macOS Catalina.
If you wish to continue using 32 Lives, please continue to do so on macOS Mojave.

Early tests shows that while install would succeed,
the 32-bit part (which runs the actual plug-in) would fail - meaning your 32-bit plug-ins won’t work at all.

We will use this thread to update on the subject.

Update June 24 2019:
Apple released first Catalina public-beta.
32 Lives and any 32-bit app will break and stop working.
Update 19 Feb 2020

(via email)
We're happy to announce that all Sound Radix plug-ins have been qualified and are now fully compatible with Apple's latest macOS Catalina. To download the latest versions, head on to your User Area.

Important: Starting with macOS Catalina, 32-bit apps are no longer compatible with macOS. Therefore, 32 Lives and legacy 32-bit plug-ins cannot work there. If you depend on legacy plug-ins for your work, we recommend installing macOS Catalina on a separate drive or partition.
Main stuff: ProTools since 1991, Logic since 2003. Now on Logic Pro X. A labor of love: Vild i min mun

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 02 Oct 2019, 20:40

Cycling '74

https://cycling74.com/articles/max-8-1- ... tarization
As of Max 8.1, we've taken the steps necessary to make Max compatible with Apple's new notarization standards. In our tests, things appear to be working well using Max 8.1 on Mac OS 10.15 beta. Despite these new complexities, Mac standalone developers should be able to distribute their applications if the the new Notarization guidelines are followed.

We understand first-hand how this change in Apple's security policy introduces inconvenience for the developer. We have worked hard to make it possible to build Max standalones that can run under the new Apple security polices, and appreciate any reports and examples where it does not work.

Read more about Apple notarization requirements: https://developer.apple.com/documentati ... stribution
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Oct 2019, 04:11

Kush Audio

(via email)
HEADS UP!

Apple is slated to release their latest MacOS update this month:

MacOS 10.15 - Catalina

We heartily recommend that all Mac-based users of Kush plugins wait to upgrade to this new OS until we've had the opportunity to update our plugin collection to meet Apple's new standards for 3rd Party software.

Our advice? Turn off Automatic Updates in your system preferences in order to keep control over when your system updates.

We'll let you know as soon as Kush Plugins are confirmed to work on Catalina!

If you run into any issues with Kush Plugins, hit us up at support@thehouseofkush.com and we'll help with whatever you need!

- The House of Kush
Update 13 August 2020
MAC USERS: The entire suite of Omega plugins are now Logic 10.5 and Catalina compatible!
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Oct 2019, 15:11

Universal Audio (UAD)

https://help.uaudio.com/hc/en-us/articl ... ility-Info
We recommend that you wait until UAD software compatibility with Catalina is announced before updating to this new operating system.
Update 25 October 2019
The current version of UAD software (UAD v9.10.2) can be installed on Catalina. However, Catalina is not yet fully tested and is currently unsupported with UAD software. Catalina is currently being tested with UAD software, and full Catalina support will be released in a future UAD software update.
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

Post Reply