laugh at my stupidity.....and then maybe help me.

System configuration, maintenance and utilities
boylan
Posts: 10
Joined: 17 Apr 2004, 08:06

Post by boylan » 18 Apr 2004, 05:30

for anyone still interested in this saga i tried the hardware test CD when i got home last night and was greeted with this msg. (not a screen dump or anything, just some bits i wrote down)

ERROR, Somebody wrote in location ZERO!!, loc zero was originally zero


Script error 101 (address ZERO) in file #0


After exiting test CD i tried to mac-boot but got 'invalid memory access at srr0' and it crashed. Also clock read 15:33:25 04/02/1976. It was around 4am. I had managed to boot the computer up before this, which took a very long time, but no CD's were recognised. Looks like i'm gonna have to seek professional help but if anyone can shed light on this error it might smooth out the fixing process. :?: :cry:

Sighmansea
Posts: 123
Joined: 21 Jan 2003, 15:49
Location: London, England
Contact:

Post by Sighmansea » 18 Apr 2004, 06:50

I remember that someone else had this problem and Markus Fritze posted saying that no damage could be caused by installing Logic with the XSKey attached. Here's that post; http://www.osxaudio.com/forums/viewtopi ... ght=#49026

Si.
PowerMac G5 Dual 2GHz, 2GB RAM, MOTU 828 MKII, Line6 Pod Pro, OSX 10.4.1, Logic Pro 7.1
Current iTMS Recommendation (Updated 21st May)

buddhabelly
Moderator
Posts: 947
Joined: 21 Apr 2003, 20:23

Post by buddhabelly » 18 Apr 2004, 12:55

My last guess on this one is 2 things:

1. CD drive
2. Bad ram

if you have extra of either of these, you could try some swapping.

Good Luck!

ferret
Site Supporter
Posts: 76
Joined: 04 Feb 2003, 10:33
Location: San Francisco, CA

Post by ferret » 18 Apr 2004, 14:01

Yeah, I think buddhabelly is on the right track. The kind of errors you're seeing are not very likely to result from any software install, or even from any USB device attached (like the XSKey). Messages about things written in wrong locations can ONLY be related to RAM or disk, actually, since those are the only things in your computer that can ever be written to. (Well, there's PRAM, but that's another story.)

I think what you're seeing is an Open Firmware message, so the problem is happening well before the operating system even begins to load. What I don't know is if that message is referring to a location in memory or on disk. I suspect it's referring to a location in memory (RAM).

Do you have multiple RAM modules installed, so that you could pull them out individually, trying to reboot after removing each one? That would test whether you have a bad RAM chip.

Of course, if it's under warranty, you might as well just let Apple handle it.

If you want to test the disk drive, and you don't have a disk drive to swap out, you may just want to buy one. They're pretty cheap these days, and if it turns out not to be the problem, it's not like the drive will be a wasted expense. You can always install it as a second drive later, or put it in a firewire enclosure and use it as an external.
Al Powerbook 1.5, 768MB RAM/Tascam US428/Korg MicroKontrol/OS X 10.3.9/Logic Pro 7.0.1/Alesis Micron

boylan
Posts: 10
Joined: 17 Apr 2004, 08:06

Post by boylan » 18 Apr 2004, 15:51

thanx for all the help guys, reckon turnkey are gonna be seein me this week.

Bosco
Posts: 5
Joined: 08 Oct 2003, 13:30

Post by Bosco » 22 Apr 2004, 20:35

The clock reset make me think that you need a new PRAM battery. Or the CD player is screwed. I had one quit on me after a week.
G4 DP 1.42/2GB RAM. Logic Pro, MOTU HD 192, 2408 MkII

User avatar
LennieJ
Site Supporter
Posts: 1350
Joined: 18 Oct 2003, 10:37
Location: Toronto, Canada

Post by LennieJ » 22 Apr 2004, 21:49

hey pardon my ignorance of all the appropriate terminology. But really, if your disc is not reading , either the disc is a dud or the drive is a dud. If your disc drive reads other discs, then the prob is obvious. Try makin a copy, if that dont work than contact the manufacturer for a new one. Just dont go messin with your puter to try & fix a hardware issue, :roll:

pchadwic
Posts: 3
Joined: 09 Oct 2002, 10:34

Try PMU or CUDA button reset...

Post by pchadwic » 24 Apr 2004, 06:51

...when all else fails. I don't have time to read this entire thread, so please forive me if I am repeating someone else's suggestion. For this kind of apparent hardware failure I would try the following (after the usual attempts to boot off a CD, FSCK single user mode, PRAM reset etc.)

Open Firmware reset:

reboot with option/command/O/F held down. When you get the grey screen type:

reset-nvram

hit return, then type

reset-all

hit return & you'll get a reboot.

If this doesn;t work, you'll need to try a hard reset using the CUDA button on the motherboard or a PMU reset (Power Management Unit).

Instructions vary with the model, here's alink at MacFixit that should also have links to Apple's Knowledge Base.

http://www.macfixit.com/article.php?sto ... ry=G4+CUDA

On a G4 1.25 x 2 machine, the CUDA button is on the motherboard & is labeled. It's very small, but you will find it if you look. Press it for 2-3 seconds, close up your machine & reboot.

Good Luck
PBook1GHz-FW800/768RAM/60GB—OSX 10.3.2—LaCieD2-120GB/MOTU828/Fastlane/KorgX5/Logic Pro 6

Post Reply