No sound thru internal speakers on my Macbook Pro

System configuration, maintenance and utilities
Post Reply
craftymusic
Posts: 12
Joined: 31 Mar 2005, 15:36
Location: London

No sound thru internal speakers on my Macbook Pro

Post by craftymusic » 28 Jan 2010, 11:12

I have a 2 and a half year old MacBook Pro with 2.4Ghz Intel Core 2 Duo Processor, 2GB Ram.

Just a couple of days ago sound stopped being output from the internal speakers. On the 'Sound' part of the System Preferences their is no longer a 'Internal Speaker' option (just 'Digital Out' and 'Aggregate Device' and, if I plug in my fireface 800 that also comes up as an option).

On Audio MIDI Setup, on Audio Devices, the Audio Output section bottom right corner of screen says 'Output is not supported'

I use Logic 8 and this is fine through the RME fireface but I often want to use internal speakers (for gigs and for internet stuff)

WTF?

I've tried a few things I can think of - Repair permissions, some Cocktail stuff, trashing prefs (although not exactly sure which prefs I should be trying...) but not getting anywhere.

Anyone got any suggestions?

Many thanks for your time...
keeping it unreal...

velocipede
Site Supporter
Posts: 945
Joined: 27 Feb 2003, 03:50
Location: Honolulu
Contact:

Re: No sound thru internal speakers on my Macbook Pro

Post by velocipede » 28 Jan 2010, 22:26

Sounds like you have tried a lot of stuff.

Maybe you did this, but I would try throwing out the "com.apple.soundpref.plist" if you have not.

This is kind of a hassle, but if possible, try installing a new system on another hard drive or partition. If the sound output is still not working when booted from a new system, it is probably a hardware problem. (Maybe you can check this by starting from a System DVD.)

Frankly, I would not be surprised if it is a hardware problem. I have a similarly aged MBP and it has issues with the optical drive and the USB and firewire ports flaking out.
MBP 2.16, Logic 8, Live 8, Numerology, enough stuff, not enough time

craftymusic
Posts: 12
Joined: 31 Mar 2005, 15:36
Location: London

Re: No sound thru internal speakers on my Macbook Pro

Post by craftymusic » 29 Jan 2010, 06:41

Thanks for the suggestions Velocipede - I've tried the prefs but no joy.
Will try booting from a DVD (as soon as I can track it down!)
I suspect it might well be hardware problem though - this baby's got a lot of miles on the clock ;)
keeping it unreal...

ottoman42a
Site Supporter
Posts: 2686
Joined: 19 Jul 2004, 23:32
Twitter: ottoman42
Location: New Haven
Contact:

Re: No sound thru internal speakers on my Macbook Pro

Post by ottoman42a » 02 Feb 2010, 08:33

Hey Crafty, I had this very issue myself once. I googled it and found a Apple support thread that suggested I play something out of iTunes then take my headphones and plumb the jack back and forth until the mac recognized the output. The trick is to not go all the way in the headphones just halfway in and halfway out. Some people said the plumbing took them a while like three minutes or more. It took me like 30 seconds at the most for the mac to see the internal speakers. Hope this helps and good luck.
Last edited by ottoman42a on 04 Feb 2010, 12:54, edited 1 time in total.
Have fun,
=Matt

Ottoble

"What's past is prologue" - Antonio
"...silence is not acoustic. It is a change of mind, a turning around." - John Cage

craftymusic
Posts: 12
Joined: 31 Mar 2005, 15:36
Location: London

Re: No sound thru internal speakers on my Macbook Pro

Post by craftymusic » 04 Feb 2010, 10:54

Thanks Ottoman, funnily enough I did this myself purely by accident and it was fixed in a nanosecond- I plugged the headphones in (in iTunes - I was there cos I launched it by accident) and, hey presto, I could hear music! I didn't realize until reading your post just now that I'd stumbled on some top secret obscure fix.....(I just thought, this computer is getting as old and as cranky as me)

Thanks for input guys
keeping it unreal...

ottoman42a
Site Supporter
Posts: 2686
Joined: 19 Jul 2004, 23:32
Twitter: ottoman42
Location: New Haven
Contact:

Re: No sound thru internal speakers on my Macbook Pro

Post by ottoman42a » 04 Feb 2010, 12:54

HA! i'm glad to hear its all fixed for ya!
Have fun,
=Matt

Ottoble

"What's past is prologue" - Antonio
"...silence is not acoustic. It is a change of mind, a turning around." - John Cage

bryanaamot
Posts: 1
Joined: 09 Mar 2011, 00:49

Re: No sound thru internal speakers on my Macbook Pro

Post by bryanaamot » 09 Mar 2011, 00:57

Wow! I had to plug in my headset about 50 times before, all of the sudden, it worked!!! The same exact thing happened to my iPhone about a year ago. Since the Mac OS and iOS have the same exact bug, then I'm pretty sure this is a software issue.

Jimmyboy
Posts: 1
Joined: 08 Jan 2013, 06:48

Re: No sound thru internal speakers on my Macbook Pro

Post by Jimmyboy » 08 Jan 2013, 06:59

Thanks Ottoman.

I just signed up to this website to say a big thank you to you for this fix.
It worked like a charm, exactly how you said, jiggling it half way in and out.
Fixed in 20 seconds.

ottoman42a
Site Supporter
Posts: 2686
Joined: 19 Jul 2004, 23:32
Twitter: ottoman42
Location: New Haven
Contact:

Re: No sound thru internal speakers on my Macbook Pro

Post by ottoman42a » 05 Mar 2013, 05:23

You're very welcome! Glad I could help and welcome to the board!
Have fun,
=Matt

Ottoble

"What's past is prologue" - Antonio
"...silence is not acoustic. It is a change of mind, a turning around." - John Cage

powas
Posts: 1
Joined: 01 May 2013, 12:50

Re: No sound thru internal speakers on my Macbook Pro

Post by powas » 01 May 2013, 12:59

Thanks Ottoman, I was really freaking out!

User avatar
G
Owner/Admin
Posts: 1983
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: No sound thru internal speakers on my Macbook Pro

Post by G » 01 May 2013, 17:18

The post that keeps on giving. :)
MacBook Pro 15" (2016) . UA Apollo x6 + Quad . macOS Catalina . Logic Pro X . TwistedWave . FCPX . PS CC . Affinity Suite . Get Info

Post Reply