macOS Catalina compatibility

System configuration, maintenance and utilities
User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 11 Oct 2019, 15:22

Softube

https://www.softube.com/support#/known- ... s-catalina
We recommend that you wait until Softube software compatibility with Catalina is announced before updating. Our development team is working diligently to ensure that all Softube software is compatible with Catalina. Complete Catalina qualification will be released in a future Softube software update.

We will make future announcements about macOS Catalina compatibility on our website. Important: to prevent macOS from updating automatically, uncheck the “Install macOS updates” option in System Preferences > Software Update > Advanced options.
Update 19 Feb 20202

(via email)
macOS Catalina installers are now available.

Please use either Softube Central (currently in beta) or the separate installers found in your Softube Account – go to https://www.softube.com/my-account#/my-products, and click either Mac or Windows.

This maintenance release has been qualified in macOS Catalina with no known issues.

Sorry for the long wait, we have been very busy cooking up nice things for you.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 25 Oct 2019, 19:35

Sonnet Technologies

https://www.sonnettech.com/support/charts/index.html

See their linked PDF file for the latest compatibility information. Almost all of Sonnet's current hardware is Catalina compatible.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 29 Oct 2019, 17:19

Bitwig

https://www.bitwig.com/en/home/news-arc ... alina.html
All testing we have done with Bitwig Studio on macOS 10.15 (Catalina) has been positive. While Bitwig Studio is compatible with Catalina, your other software and hardware may not be due to several major changes in macOS, including:
  • 32-bit plug-ins do not work anymore, in Bitwig Studio or anywhere else. This was Apple's decision, and it also applies to 32-bit applications and drivers.
  • All hardware drivers must be updated. This includes any audio interfaces or MIDI controllers that are not class compliant.
  • More changes are coming in January. Bitwig Studio will be updated at that time and remain compatible, but this means additional third-party software (such as 64-bit plug-ins) will need to be updated as well. We will update you in advance of this.
Please be aware of these new and coming changes from Apple before electing to change your operating system.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Nov 2019, 04:42

Kazrog

https://kazrog.com/blogs/news/macos-catalina-statement
UPDATE: Kazrog has announced preliminary support for macOS Catalina, as of October 16, 2019. While more thorough testing has yet to be done, we can confirm that our current plugins are working in hosts that officially support Catalina at this time.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Nov 2019, 14:42

RME

https://www.synthax.co.uk/latest/2019/1 ... ace-users/
RME’s latest driver (v3.18) provides compatibility between OS Catalina and all RME USB audio interfaces, as well as supporting Apple’s “Notarization” requirement. Beta drivers are also available for RME’s non-USB interfaces (PCle, Thunderbolt and FireWire), so other RME users won’t experience any interruption or delay in their projects either.

MacOS Catalina - RME Audio Interfaces - Synthax Audio UKThe following RME interfaces are immediately compatible with macOS 10.15:

Fireface UFX / UFX+ / UFX II / 802 / UCX / UC
Babyface
Babyface Pro
MADIface USB
MADIface XT
MADIface Pro
Digiface USB
Digiface Dante
Digiface AVB
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Nov 2019, 15:04

Sonnox

https://sonnox.freshdesk.com/support/so ... patibility
Sonnox have been working with Apple to test our plug-ins throughout the beta stages of Catalina, and we're pleased to say that most, if not all, compatibility issues have been ironed out prior to public release.

If you're considering upgrading, you should ensure you have the latest versions of all your Sonnox software and iLok drivers installed. Because Catalina will no longer support 32-bit applications, you must be using Sonnox G5 licences; if your plug-ins are still G4, you will need to upgrade to G5 to add 64-bit installers for your plug-ins.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 04 Nov 2019, 15:06

iLok

https://www.ilok.com/#!aux
5.1.x Release Notes

For Macintosh users, this update requires a minimum of OS X v10.8 Mountain Lion.

• Apple notarization compliance and compatibility with macOS 10.15 Catalina
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 06 Nov 2019, 20:05

DSP-Quattro

https://www.dsp-quattro.com/dspquattro/ ... on-history
Version 5.2:

⁃ MacOS 10.15 Catalina is fully supported: the application is now “notarized” and compiled to be fully compatible also with MacOS 10.15 Catalina.
⁃ code optimisation and minor bugs fixed.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 07 Nov 2019, 20:01

TwistedWave

https://twistedwave.com/mac
Supported on macOS 10.9 up to macOS 10.15 Catalina.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 15 Nov 2019, 02:49

Klanghelm

https://klanghelm.com/
News
macOS Catalina compatibility, VST3 versions
Friday, November 15, 2019

Maintenance updates for all Klanghelm plugins have been released. All Klanghelm plugins are now fully compatible with macOS Catalina and also include VST3 versions.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 15 Nov 2019, 03:17

Fuse Audio Labs

https://fuseaudiolabs.com/#/posts/2019- ... 5c-release
We have extensively tweaked our entire portfolio and are proud to offer Fuse V2 completely for free, including sophisticated and more refined user interfaces, a bunch of functional improvements, and full support of macOS Catalina (10.15) for our complete line of products.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 18 Nov 2019, 13:04

United Plugins

https://unitedplugins.com/news/detail/32
...great news for macOS users. We have crossed the obstacles of Catalina compatibility and our software now works flawlessly on this version of macOS. Still, we recommend waiting with the upgrade to Catalina till all plugins by your other favourite brands are compatible.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 23 Nov 2019, 16:23

Beatskillz

https://www.beatskillz.com/shop/valvesque/ or any other product
System Requirements
macOS High Sierra 10.13.6 or later ( Does not support MacOS Catalina )
Asked for clarification and received this answer:
We are currently not working on Catalina Updates. However, in the future, we might release the updates, which you can get for Free. Subs to our Newsletter for updates.
Update 24 Jan 2020
Our plug-ins do not support the latest version of the macOS yet.

However, we are working on the new updates and it will be out soon for free.

Kindly subscribe to our newsletter for all the latest updates.
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 16 Dec 2019, 01:57

Inphonik

https://www.facebook.com/inphonik
Our products RX950, RYM2612 and RYMCast are macOS 10.15 Catalina compliant!
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

User avatar
G
Owner/Admin
Posts: 1968
Joined: 05 May 2003, 18:11
Twitter: glenngutierrez
Location: SF Bay Area, California
Contact:

Re: macOS Catalina compatibility

Post by G » 16 Dec 2019, 15:25

Black Rooster Audio

https://blackroosteraudio.com/en/newsre ... ate-v2-4-2
Version 2.4.2 of our plug-ins is now available for free on our website. It includes various bug fixes, and also support of MacOS Catalina 10.15 and above. Enjoy!
MacBook Pro 15" (2016) . Radeon Pro 460 . UA Apollo x6 . macOS Mojave . Logic Pro X . FCPX . PS CC . Get Info

Post Reply